Go Back   FlashFXP Forums > > > >

NeoXed's scripts nxAutoNuke, nxTools, etc.

Thread Tools Rate Thread Display Modes
Old 03-09-2008, 12:24 PM   #1
Junior Member
FlashFXP Registered User
Join Date: Apr 2004
Posts: 6
Default Configuring nxMyDB to use SSL

Okay..I am trying to get SSL working here, and I think I am almost there... I already have a working nxmydb-thing running, but not encrypted.

First I followed the instructions on http://dev.mysql.com/doc/refman/5.0/...ate-certs.html to create the SSL-certs, and I configged mysql to use them. I can connect locally using SSL.

Next I edited my ioftpd.ini to add the ssl-stuff:
Host            =
Port            = 1234
User            = username
Password        = password
Database        = ioftpd        # Database name
Compression     = True          # Use compression for the server connection
Sync            = True          # Synchronization of users and groups
Sync_First      = 30            # Seconds until the first full synchronization
Sync_Interval   = 60            # Seconds between each incremental synchronization

SSL_Enable      = True
SSL_Ciphers     = DHE-RSA-AES256-SHA 
SSL_Cert_File   = c:\ioftpd\system\client-cert.pem 
SSL_Key_File    = c:\ioftpd\system\client-key.pem 
SSL_CA_File     = c:\ioftpd\system\ca-cert.pem
SSL_CA_Path     = c:\ioftpd\system
Is there anything else I need to do? When I run ioftpd with these settings, I get a whole bunch of errors in nxMyDB.log telling me it can't access the mysql-server

Last edited by Scuttle; 03-09-2008 at 12:45 PM.
Scuttle is offline   Reply With Quote

compression, seconds, ssl, synchronization, true

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

All times are GMT -5. The time now is 02:14 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)